WordPress припинить оновлення системи безпеки для версій 3.7–4.0 до грудня 2022 року – WP Tavern

WordPress припинить оновлення системи безпеки для версій 3.7–4.0 до грудня 2022 року – WP Tavern

ви можете скористатись послугами веб-студії філандор, Замовити Сайт тут. Студія не перший рік надає послуги.

Команда безпеки WordPress оголосила про припинення підтримки версій 3.7–4.0 1 грудня 2022 року. Щоб зрозуміти, скільки років цим версіям, у 2013 році WordPress 3.7 представив автоматичні фонові оновлення, а 3.8 оновив адміністратор із новим дизайном. на основі плагіна MP6.

Офіційна політика WordPress полягає в тому, що команда безпеки надає підтримку лише для останньої версії, але як люб’язність розширила резервне портування виправлень безпеки для старіших версій, які можуть отримувати автоматичні оновлення.

«До цього часу ці безкоштовні бекпорти включали всі версії WordPress, які підтримують автоматичне оновлення», — сказав Пітер Вілсон, член команди безпеки, спонсорованої 10up. «Версії WordPress 3.7 – 4.0 досягли рівня використання, а саме менше 1% від загальної кількості встановлень, де переваги надання цих оновлень переважують зусилля, які були б витрачені».

Більше половини всіх сайтів WordPress працюють на останній версії – 6.0+ (54,3%), і після цієї зміни оновлення безпеки залишаться доступними для більш ніж 99% сайтів на старіших версіях. Вілсон сказав, що рішення припинити підтримку версії 3.7–4.0 ґрунтувалося на інформації, представленій на сторінці статистики.

WordPress припинить оновлення системи безпеки для версій 3.7–4.0 до грудня 2022 року – WP Tavern
Статистика версії WordPress – 07.09.2022

«Ефект цього дисбалансу означає, що команда безпеки витрачає більшу частину часу на підготовку бекпортів для переважної меншості інсталяцій WordPress», — сказав Вілсон. «Завдяки припиненню підтримки цих старих версій нові версії WordPress стануть безпечнішими, оскільки більше часу можна буде приділяти їхнім потребам».

Протягом наступних трьох місяців версії 4.0 і старіші отримають останні оновлення, а також відображатимуть повідомлення, яке не можна відхиляти, на інформаційній панелі, порадивши користувачам оновити до останньої версії, оскільки їхні сайти більше не отримуватимуть оновлення безпеки.

Джерело: https://wptavern.com/wordpress-to-drop-security-updates-for-versions-3-7-through-4-0-by-december-2022

Related posts